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Visualisation (T26)
The Visualisation tool enables you to visualise all INTREPID datasets.  It includes 
the following customisable display features:  You can:
• Display single bands of grid datasets using:

• Pseudocolour (based on ranges of values or a histogram) 
• Grey scale
• Sun angle
• Pseudocolour with sun angle drape
• Contours.  

• Display ternary (3 band) grid datasets (usually radiometrics)
• Display line datasets and show the values of a Z field using: 

• Pseudocolour
• Profiles

• Display point datasets and show the values of up to three Z fields, using:
• Marker colour
• Marker size
• Marker angle
• Marker text

• Display polygon datasets, create new ones and turn label display on and off
• Overlay a number of vector datasets on each other and on a grid dataset
• Zoom and pan the display
• View data values by clicking points on the display

Using the Visualisation tool

>> To use the Visualisation tool with the INTREPID graphic user interface
1 Choose Visualisation_tool from the Edit menu in the Project Manager, or use the 

command visual.exe.  INTREPID displays the Visualisation tool Main window.

Top
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2 If you are about to display a large line or point dataset and want to speed up the 
data display on the screen, adjust the display subsampling rate for line or point 
datasets using the Display Subsampling option from the Line Display menu.  (See 
"Setting the display subsampling interval" for details).

3 If you have prepared settings for your display, load the corresponding task 
specification file using Load Options from the File menu. (See "Specifying input 
and output files" for detailed instructions.)  
If you do not want to load any further datasets, go to step 5.  

4 Specify the datasets for display.  Use Load Line Dataset, Load Point Dataset, 
Load Poly Dataset, Load Grid Dataset and Load Ternary Grid from the File menu 
as required.  (See "Specifying input and output files" for detailed instructions.)  
If you are displaying a point dataset INTREPID asks you to specify the Z fields for 
marker colour, size, angle and text.  Click Cancel for the display attributes you do 
not want.
If you are displaying a line dataset you can specify the Z field for pseudocolour and 
profile display using Load Z Field for Line Dataset in the Line Display menu.
You can load up to ten of each type of vector dataset (point, line, polygon).
You can turn display on and off for each type of dataset.
INTREPID displays the datasets in the Visualisation tool Main window.

5 Examine and manipulate the display of the datasets according to your 
requirements as follows.  

• If you are viewing a grid dataset, switch between grey scale, pseudocolour, sun 
angle and sun angle drape displays.  Change the parameters for these display 
formats as required using options from the Grid Display menu (See "Grid dataset 
display (single band)" for details).

• If you are viewing a points dataset, turn colour and size Z data display on and off 
as required. (See "Point dataset display" for details.)

• If you are viewing a line dataset display a Z field using colour or stack profile (See 
"Specifying input and output files" for detailed instructions.

• If you require a new polygon, trace it, specify a label and save it as a new polygon 
dataset if required (See "Specifying input and output files" for detailed 
instructions).

• Zoom (enlarge an area of the display) and pan (examine different regions while 
enlarged) (See "Zooming and panning the display" for information).

• Query points or distances in the dataset display.  INTREPID will report 
information about the points in the Visualisation tool Main window (See 
"Querying points" for details)

6 If you want to record specifications from this session as a task specification (.job) 
file, use Save Options from the File menu. (See "Specifying input and output files" 
for detailed instructions.)

7 To exit from Visualisation tool, choose Quit from the File menu.
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Notes:
• You can control the effect of mouse operations in the dataset display area using 

the Mouse Mode options in the Command area of the Visualisation tool Main 
window.  See "Mouse mode summary" for details.

• To view the current display specifications choose Report from the Window menu.  
INTREPID displays the Visualisation tool Report window.  See "Displaying 
options and using task specification files" for details and an example of a set of 
specifications.

• You can view Help information by choosing options from the Help menu (See 
"Help").

Specifying input and output files
You need to specify the datasets for viewing in the Visualisation tool.  If you want to 
examine the Z data from a line or points dataset during the process, you must also 
specify the Z fields.  If you trace a new polygon, you can save it as a polygon dataset.

INTREPID identifies the X, Y, line number and fiducial fields using dataset aliases.  
The dataset must have the following aliases, identifying appropriate fields.

* These fields are optional.  If you do not specify them, INTREPID will prompt you 
with an Open dialog box to specify them.  If you do not specify them INTREPID will 
use a default system to create the missing numbers (See "Line, fiducial and point 
numbers" for details).

See "Alias de campos en conjuntos de datos vectoriales" in Estructura de directorios y 
archivos INTREPID (R05) for more information about aliases.  

Choose the options as required from the File menu.  You can also save a traced 
polygon as a new polygon dataset, using the Polygon Display menu.

In each case INTREPID displays an Open or Save As dialog box.  Use the directory 
and file selector to locate the file you require.  (See "Specifying input and output files" 
in Introduction to INTREPID (R02) for information about specifying files).  

INTREPID also often displays a field or band selection dialog box.  Follow the 

Alias Field

X X coordinate (geographic location)

Y Y coordinate (geographic location)

LineNumber line number *

FID fiducial sequence *
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instructions for the type of dataset you are loading.

If you have already opened a vector dataset of similar type, INTREPID asks if you are 
replacing the existing dataset or adding another.  See "Displaying multiple vector 
datasets" for detailed instructions.
Load Line Dataset Use this option to specify line datasets.  INTREPID opens the 

dataset, locates the X and Y geographic coordinate fields using dataset aliases and 
display the lines in the Visualisation tool Main window.

Load Point Dataset Use this option to specify a point dataset.  See "Point dataset 
display" for instructions. 

Load Polygon Dataset Use this option to specify a polygon dataset.  See "Polygon 
dataset display" for instructions.

Load Grid Dataset Use this option to specify a single band of a grid dataset.  If you 
specify a multiband grid, INTREPID displays the Select Band dialog box.  See 
"Grid dataset display (single band)" for instructions.

Load Ternary Grid Use this option to specify a multiband grid dataset.  See 
"Ternary Grid display" for instructions.

Load Options If you want to use an existing task specification file to specify the 
display, use this option to specify the task specification file required.  INTREPID 
will use the file to create the display.  (See "Displaying options and using task 
specification files" for more information).

Save Options Use this option to save the current Visualisation tool display 
specifications as a task specification file.  (See "Displaying options and using task 
specification files" for more information).

Load Z field for Line Dataset (Line Display menu) Use this option to specify the Z 
field for both:
• The Z data colour display.  See "Showing Z values as line colour" for details.
• The Z data stack profile display See "Viewing Z data profile" for details.

Save Traced Polygon (Polygon Display menu) Use this option to save a polygon you 
have just traced as a new polygon dataset.   See "Polygon dataset display" for 
more information.
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Displaying multiple vector datasets
If you have already specified one or more vector datasets of a certain type (point, line, 
polygon) and then go to load another, INTREPID asks you whether to add the new 
dataset to the display or replace the most recently loaded dataset.  It displays the Add 
or Replace ... Dataset dialog box.  This dialog box operates in the same way for line, 
point and polygon datasets.  When you read this section you can substitute line, point 
or polygon for ‘...’ as required.

• To add the dataset, click Add another ... dataset.  
• To replace the previously loaded dataset, click Replace ... dataset last loaded.
• You can also click Cancel loading the ... dataset.
The following picture shows a display with two line datasets.

Note: In the current version of the Visualisation tool:
• You must specify Z fields and display characteristics for each vector dataset before 

you load the next dataset.  
• The Z field display controls only work for the most recently loaded dataset.  
• You can replace the most recently loaded dataset but you cannot unload a dataset.
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Mouse mode summary
The Visualisation tool has three basic mouse operations, determined by the mouse 
mode options located at the bottom of the Main window Command area.

>> To select a mouse mode
Select the corresponding Mouse mode option button.
Zoom or Trace Using this mode you can define rectangular regions for zooming the 

data display and trace new polygons.  See "Zooming and panning the display" for 
details.

Query Using this mode you can click points and drag between pars of points to obtain 
information about the data they represent.  See "Querying points" for details.

General display controls and options
While using the Visualisation tool with one or more datasets you can
• Zoom (enlarge parts of the display) and pan (view different regions of the dataset 

displayed when it has been enlarged) See "Zooming and panning the display".
• View information about points or pairs of points in the display.  See "Querying 

points".
• Control time and speed of screen redrawing.  See "Screen redrawing" and "Setting 

the display subsampling interval".

Zooming and panning the display
You can enlarge and reduce the display (zoom in and out) and view different parts of 
it (pan).  

>> To zoom in and out (enlarge/reduce) by steps
To zoom in (enlarge the display) choose Zoom In in the Command area of the 
Visualisation tool Main window.   Each time you choose this button, INTREPID will 
enlarge the display by 25%.

To zoom out (reduce the display) choose Zoom Previous in the Command area of the 
Visualisation tool Main window.   Each time you choose this button, INTREPID will 
return to the previous zoom level.

You can use these buttons at any time, no matter what mouse mode you have 
selected.
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>> To zoom in on a selected area of the display
Select Zoom from the Mouse Mode options.  

Hold down the left mouse button and drag diagonally (corner to corner) across the 
area that you want to enlarge.  INTREPID will enlarge the selected region to fill the 
Data area of the window.  If you choose Zoom Previous, having used this zooming in 
process, INTREPID will immediately zoom out to the full dataset display.

The illustration below is the a zoomed-in part of the grid dataset illustrated in section 
"Grid dataset display (single band)".

>> To pan a zoomed-in display (view different parts)

The Pan/zoom indicator at the right of the Visualisation tool Main window in the 
centre consists of a small square within a larger square.  The large square represents 
the whole display and the small square the part visible on the screen.  When you drag 
the small square to a different part of the large square INTREPID shows the 
corresponding part of the display.
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If you have zoomed out to view the whole display, the small square may occupy the 
whole of the large square and may therefore not be visible.

You can use the Pan/zoom indicator at any time, no matter what Mouse Mode you 
have selected.

Querying points
INTREPID can display information about 
• Individual points if you click them in your display or 
• Start and finish points if you mouse drag across a section of the display.
This section describes the information obtained while you are using Query mouse 
mode.

INTREPID displays information about the query points in the Status area.  This is  
at the top of the Command area in the Visualisation tool Main window.

>> To select Query mouse mode 
Select Query from the Mouse Mode option buttons near the lower left corner of the 
Visualisation tool main window.  

>> To view information about a point
Click it with the left mouse button and view the information in the Status area.

>> To view information about a pair of points
Drag from one point to the other using the left mouse button, then view the 
information in the Status area.

If INTREPID is displaying a grid without a line dataset, it displays information about 
the point on the grid that you click.

If INTREPID is displaying a line dataset, it displays information about the nearest 
point on a line to the click point.  
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How to read the status area
The following definitions, diagram and tables will help to explain the way that 
Visualisation tool reports information to you.

The click point is the position on the display which you click with the left mouse 
button. 

The start point and finish point are the mouse button down and mouse button release 
points when you perform a left mouse button drag across part of the display.

If you consider a traverse line display as a set of line segments joining  data points, 
the point on a line nearest to the click point is the point on a line segment nearest to 
the click point.

The following illustration shows a click point, data points and lines.

Notes: 
• Vector dataset data displayed comes from the most recently loaded vector dataset.  
• The names of datasets at the top of the status area asre the most recently loaded
The following table describes the information shown in the Status area during single 
click query operations.

Heading Grid only Line or Line + Grid Point or Point + Grid

X, Y X, Y coordinate 
of click point

X, Y coordinates of data point 
nearest to click point

X, Y coordinates of data point 
nearest to click point

Z field n/a Loaded Z field name Colour Z field name

Line n/a Line number of data point 
nearest to click point

Line dataset also present: Line 
number of data point nearest to 
click point

Line dataset not present: n/a

Fid n/a Fiducial number of data point 
nearest to click point

n/a

Grid Val Value of grid cell 
at click point

Value of grid cell at click point 
(if grid dataset displayed) 

Value of grid cell at click point (if 
grid dataset displayed)

Dist (m) n/a Distance from click point to 
nearest data point

Distance from click point to 
nearest data point
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The following table describes the information shown under these headings during 
left mouse button drag query operations

Line, fiducial and point numbers
If the dataset has a line numbers alias (LineNumber), INTREPID uses the line 
numbers from this field.

If there is no LineNumber alias, INTREPID assigns line numbers to the data 
groups (lines) as they occur, starting with 0.

If there is a Fiducial alias, INTREPID uses the data in the fiducial field.

If there is no Fiducial alias, INTREPID assigns fiducial sequence numbers to the 
points as they occur in the dataset, starting with 0.  

Screen redrawing
The Visualisation tool is designed to work with datasets of unlimited size.

Large datasets require lengthy processing and therefore screen redrawing may take 
some time.  In order to show you the most up to data version of the datasets 
displayed, INTREPID performs redraws after most operations.  

You can speed up redraws by reducing the sub-sampling rate of vector datasets.  See 
"Setting the display subsampling interval" for instructions.

Due to our efforts to minimise screen redraws, INTREPID may fail to redraw the 
screen occasionally when you do require a redraw.  

Heading Grid only Line or Line + Grid Point or Point + Grid

X, Y X, Y coordinates 
of start point

X, Y coordinates of data point 
nearest to start point

X, Y coordinates of data point 
nearest to start point

Z field n/a Loaded Z field name Colour Z field name

Line n/a Line number of data point 
nearest to start point

Line dataset also present: Line 
number of data point nearest to 
start point

Line dataset not present: n/a

FID 1 n/a Fiducial number of data point 
nearest to start point

n/a

Val Value of grid cell 
at start point 

Value of grid cell at start point Value of grid cell at start point

Dist (m) Distance between 
start point and 
finish point

Grid present: Distance 
between start point and finish 
point

Grid not present: Distance 
from data point nearest start 
point to data point nearest 
finish point

Grid present: Distance between 
start point and finish point

Grid not present: Distance from 
data point nearest start point to 
data point nearest finish point
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If you need to trigger a screen redraw

>> To trigger a screen redraw
• Click the pan/zoom indicator square in the Command area or
• Change the size of the Visualisation tool window slightly by dragging its border.

Setting the display subsampling interval
Each time you perform an operation or change an option, INTREPID redraws the 
screen.  For a large vector dataset, this may take too long.  You can speed up the 
display (at the cost of display detail) by reducing the subsampling interval.  For 
example, if you set the subsampling interval to 2, INTREPID will only display every 
second data point on the screen.  

You can set the subsampling interval separately for point and line datasets.

>> To specify the subsampling interval for line or point datasets:
1 Ensure that you are using Zoom mouse mode.
2 Choose Set Subsample Interval  from the Line Display menu or Point Display 

menu.  INTREPID displays the Subsampling for Display dialog box.

Specify the subsampling interval in the Interval text box and choose OK.  
INTREPID  redraws the display with the new subsampling interval.
Note: Increasing the value of the Interval parameter means that INTREPID 
displays fewer data points.  

Grid dataset display (single band)
If you are viewing a single band of a grid dataset you can choose pseudocolour, grey 
scale, sun angle or sun angle drape display.  INTREPID uses sun angle drape when it 
first displays the grid.

Use the options from the Grid display menu to specify your grid display method.
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Displaying grid datasets

>> To load a grid dataset
1 Use Load Grid Dataset from the File menu.  
2 INTREPID prompts you specify the grid dataset, using an Open dialog box.  See 

"Specifying input and output files" for details.
3 If you specify a multiband grid, INTREPID displays the Select Band dialog box. 

Select the band you require and click OK.  If you click Cancel, INTREPID loads 
band 1.

4 INTREPID displays the dataset. If there is already a grid dataset in the display, 
INTREPID replaces it with the new grid.

>> To turn grid dataset display on and off
Use Hide Grids in the Grid Display menu to show or hide the grid dataset you have 
loaded.  The menu option has a check mark if grid display is hidden.

Pseudocolour display
If you choose pseudocolour display without modifying the Low Clip and High Clip 
parameters INTREPID will apply a fixed range pseudocolour display to your grid.  
This involves dividing the range of cell values in your grid into equal parts 
corresponding to pseudocolour values and assigning colours to the cell values 
accordingly.  The 256 basic pseudocolour values are set out in the lookup table 
pseudocolour.lut  (See "Tablas de aspecto (lookup) en color" in Estructura de 
directorios y archivos INTREPID (R05) for details).

If you set Low Clip or High Clip values  INTREPID will assign 
• The lowest ranking colour to all grid cells whose value is less than or equal to the 

Low Clip value.
• The highest ranking colour to all grid cells whose value is greater than or equal to 

the High Clip value.
• The other colours in the pseudocolour range to other cells in the grid on the basis 

described above.
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>> To specify pseudocolour display for your grid
1 Choose Grid With Pseudocolour from the Grid Display menu.  INTREPID 

displays the Pseudocolour for Grid Dataset dialog box.

2 Specify or reset Low Clip and High Clip values if required 
To restore the Low Clip and High Clip values to the minimum and maximum cell 
values, choose Reset.  Otherwise enter the values (in Z units) in the corresponding 
text boxes.

3 Choose OK.
INTREPID displays the grid using pseudocolour.
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Grey scale display
If you choose grey scale display without modifying the Low Clip and High Clip 
parameters INTREPID will apply a fixed range grey scale display to your grid.  This 
involves dividing the range of cell values in your grid into equal parts corresponding 
to grey scale values and assigning colours to the cell values accordingly.  The 256 
basic grey scale values are set out in the lookup table greyscale.lut  (See "Tablas 
de aspecto (lookup) en color" in Estructura de directorios y archivos INTREPID (R05) 
for details).

If you set Low Clip and/or High Clip values  INTREPID will assign 
• The lowest ranking shade to all grid cells whose value is less than or equal to the 

Low Clip value.
• The highest ranking shade to all grid cells whose value is greater than or equal to 

the High Clip value.
• The other shades in the grey scale range to other cells in the grid on the basis 

described above.

>> To specify grey scale display for your grid
1 Choose Grid With GreyScale from the Grid Display menu.  INTREPID displays 

the Pseudocolour for Grid Dataset dialog box.

The Low Clip and High Clip text boxes will at first contain the minimum and 
maximum cell values.

2 Specify or reset Low Clip and High Clip values if required 
To restore the Low Clip and High Clip values to the minimum and maximum cell 
values, choose Reset.  Otherwise enter the values (in Z units) in the corresponding 
text boxes.
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3 Choose OK.
INTREPID displays the grid using grey scale.

Sun angle display and sun angle drape 
Sun angle display creates the illusion of the sun shining on the image from a chosen 
angle, creating a system of illuminated areas.  

The sun angle effect enables you to visualise the grid in terms of 'hills' and 'valleys'.  
It interprets a high measurement in a sample as a 'hill' and a low measurement as a 
'valley'.  

You can use sun angle this even though the measurements in the data may not 
actually be physical elevation.  For example, if the measurements are levels of 
magnetism, the sun angle display allows you to visualise a 'magnetic topography' 
where 'hills' are areas of high magnetism, and 'valleys' are areas of low magnetism.

This display mode is useful for highlighting linear trends or breaks in the grid that 
may be missed in ordinary colour or grey scale coded viewing.

Sun angle display uses greys to show the sun angle effect.

Sun angle drape is a sun angle display draped over a pseudocolour display.
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>> To specify sun angle or sun angle drape display for your grid
1 Choose Sun Angle or Sun Angle Drape from the Grid Display menu.  INTREPID 

displays the Sun Angle for Grid dialog box.

2 Specify Declination, Inclination and Vertical Exaggeration as required, then 
choose OK.  INTREPID displays the grid in sun angle format.

Declination is the 'compass' direction of the line from the overhead point to the 'sun'.  
A declination of 0° means that the 'sun' is North of the overhead point.  A 
declination of 90° means that it is East of the overhead point.  –90° means West 
and +180°or –180° means South.  The default declination is 45°

Inclination is the angle of the 'sun' between the horizon and the overhead point.  An 
inclination of  0° means that the 'sun' is on the horizon and an inclination of  90° 
means that it is at the overhead point.  The default inclination is 45°

Vertical Exaggeration is the size of the contrast between high and low values.  If 
you increase the Vertical Exaggeration, the 'hills' will appear higher and the 
'valleys' deeper.  The default vertical exaggeration is 100.

Here are illustrations of sun angle and sun angle drape displays.

Sun angle Sun angle drape 
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Modifying the parameters of the current display format
You can modify the parameters of the current grid display format by choosing its 
menu option again (or applying an equalisation histogram).

>> To modify pseudocolour, grey scale or sun angle display parameters.
1 Choose Grid with Pseudocolour or Grid with Sun Angle accordingly from the Grid 

Display menu.  INTREPID displays the corresponding dialog box.  
2 Modify the parameters as required and choose OK.  INTREPID displays the grid 

using the modified parameters.

Contours
You can place contour lines on a pseudocolour or grey scale grid display.

>> To display contour lines:
1 Ensure that your grid is in pseudocolour or grey scale mode.
2 Select Contour from the Grid Display menu.  INTREPID displays the Contour 

Options dialog box.

 
3 Specify the contour interval in Z data units and then click OK. INTREPID places 

a tick beside the menu option and displays the grid with contours.
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>> To remove contours from the display:
Select Contours from the Grid Display menu.  INTREPID removes the tick from the 
option.

Equalising histogram
If you are using the grey scale or pseudocolour display, you can use an equalising 
histogram to distribute the colours or shades so that each colour or shade has the 
same area in the display (the same number of grid cells).

>> To turn on the equalising histogram display
1 Ensure that you are displaying the data using grey scale or pseudocolour.
2 Choose Histogram from the Grid Display menu.  INTREPID displays the 

Histogram Options for Grid Dataset dialog box.

3 Set the Bin Width parameter if required and choose OK.  INTREPID places a tick 
beside the menu option and redisplays the grid using the equalising histogram. 

Bin width In a piecewise linear histogram the data is grouped in 'bins' according to 
rank.  Each 'bin' contains a fixed number of data items of approximately the same 
value.  The bin width parameter specifies the percentage of the data occupying 
one 'bin'.  The default value of .3 results in about 330 bins.  If you increase the bin 
width, resulting in fewer 'bins', the data will have larger clusters and fewer 
different colours.  If you decrease the bin width, resulting in more 'bins', the data 
will have smaller clusters and a greater variety of colours.
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Restretch after every pan and zoom If you tick this check box, INTREPID 
reapplies the histogram each time you pan or zoom, recalculating the equal colour 
or shade distribution based on the visible area of the display.

>> To turn off the equalising histogram display
1 Choose Histogram from the Grid Display menu.  INTREPID removes the tick 

from the option.
2 If necessary, click the pan/zoom indicator box or slightly adjust the window size to 

force a screen redraw.

Ternary Grid display
This feature is for displaying radiometrics and other multiband grids.

You can display three grid bands at the same time, assigning bands to red, green and  
blue.  You can use knowledge of colour addition to interpret the colours on the 
display.  For example, a yellow area has red (potassium) and green (thorium).  We can 
drape total count or magnetic data as sun angle display over the colours. The 
following table shows the appearance and normal purpose of each band in the ternary 
grid display.  It lists the bands in the order that the Visualisation tool requests them 

Normal pseudocolour Equalising Histogram 

Band order in Visualisation Purpose Display

1 potassium red

2 thorium green

3 uranium blue
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When you specify a ternary grid for display INTREPID displays the grid band 
chooser dialog box for each band.

Select each band according to your requirements.  

If you click Cancel for the Red band, INTREPID loads band 1.  

If you click Cancel for the Green INTREPID loads the band number one greater than 
the Red band.  

If you click Cancel for the Blue INTREPID loads the band number one greater than 
the Green band.  

Here is an illustration of a ternary grid display.
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Line Dataset display
The line dataset display has a large range of display options to enable you to both 
view and edit the dataset.  You can:
• Balance screen redraw speed with display detail (in Zoom mouse mode) by 

specifying the display subsampling rate.  See "Setting the display subsampling 
interval" for details

• Click any part of any traverse line using the mouse and view (for the nearest data 
point) the X and Y coordinates, the traverse line number, the number and fiducial 
number.  See "Querying points" for details. 

• For a selected Z field, apply fixed range pseudocolour to the lines indicating values 
of the Z data.  See "Showing Z values as line colour" for details.

• For a selected Z field, view the field as a profile superimposed on the traverse 
lines.  See "Viewing Z data profile" for details.

If you require a Z field for use in the display, specify it using the Load Z Field for Line 
Dataset option from the Line Display menu (See "Specifying input and output files" 
for details).

You can control the line dataset display features using options from the Line Display 
menu.

The following illustration shows a line dataset as the Visualisation tool originally 
displays it.
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Displaying line datasets

>> To load a line dataset
1 Use Load Line Dataset from the File menu.  
2 If there is already a line dataset in the display, INTREPID displays the Add or 

Replace Point Dataset dialog box.  See "Displaying multiple vector datasets" for 
instructions

3 INTREPID prompts you specify the line dataset, using an Open dialog box.  See 
"Specifying input and output files" for details.  INTREPID displays the dataset.

>> To specify a Z field for colour and profile display
1 Choose Load Z Field from the Line Display menu.  INTREPID requests the Z field 

using a field choice dialog box. 

>> To turn line dataset display on and off
Use Hide Lines in the Line Display menu to show or hide the line datasets you have 
loaded.  The menu option has a check mark if points display is hidden.

Showing Z values as line colour
If you have specified a Z field you can display its values using fixed range 
pseudocolour.  INTREPID will colour the traverse line paths in the display according 
to the value of the Z field.  INTREPID assigns the colours from the 
pseudocolour.lut lookup table (See "Tablas de aspecto (lookup) en color" in 
Estructura de directorios y archivos INTREPID (R05) for more information)
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>> To display the Z field as line colour
1 Ensure that you have specified a Z field (See "Displaying line datasets").
2 Choose Z Value as Line Colour from the Line Display menu.  INTREPID displays 

the line colours accordingly.

>> To turn off  Z value as line colour display
Choose No Line Colours from the Line Display menu.

Viewing Z data profile
If you have specified a Z field you can view a display of Z data as a profile.  In this 
display INTREPID distorts the traverse line paths into ‘hills and valleys’ that 
illustrate the value of the Z field.

>> To display Z profiles
1 Ensure that you have specified a Z field (See "Displaying line datasets").
2 Choose Show Profile of Z from the Line Display menu.  INTREPID displays the 

Profile Settings for Z Field dialog box.
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3 Specify the parameters according to your requirements and choose OK.  
INTREPID displays the Z Profiles.

Offset The Offset is the relative height of the profile display in Z units per display 
centimetre.  INTREPID subtracts the Z data base value before calculating the 
profile height.

Base Value In the context of profile display in the Visualisation tool, we recommend 
that you use a base value of 0.

4 Adjust the parameters as required by turning off stack profile display (select the 
menu option agin) and then repeating steps 1 and 2 above.

>> To turn off display of the Z stack profile
Choose Show Profile of Z from the Line Display menu.  INTREPID will redraw the 
display without the Z profile.

>> To modify the Z stack profile parameters
Turn Z stack profile display off, then on again.  When you turn it on INTREPID 
displays the Profile Settings for Z Field dialog box again (see above for instructions).
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Point dataset display
You can display a point dataset using square or angled line markers.  INTREPID can 
vary the size, colour and angle of the markers according to the values in Z fields.  
Specifically, you can select Z fields whose values detemine:
• Size of square point markers in the display
• Colour of the point markers in the display
• Angle of line-shaped point markers in the display  
• Labels for the points displyed.  
You can turn these aspects of the display on and off as required.

If you enable angle display, the point markers are line-shaped.  If you disable this 
display, the point markers are square.

In each case INTREPID assigns the sizes, colours or angle according to a fixed range 
system, where each size or colour has a value range the same size.  INTREPID 
assigns the colours from the pseudocolour.lut lookup table (See "Tablas de 
aspecto (lookup) en color" in Estructura de directorios y archivos INTREPID (R05) for 
more information) INTREPID assigns sizes and angles according to the range of Z 
values.

You can balance screen redraw speed with display detail (in Zoom mouse mode) by 
specifying the display subsampling interval.  See "Setting the display subsampling 
interval" for details

The following illustrations are of Euler Deconvolution results estimating depth of 
magnetic sources.

Square point markers Line-shaped point markers with labels
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Displaying point datasets

>> To load a point dataset
1 Use Load Point Dataset from the File menu.  
2 If there is already a point dataset in the display, INTREPID displays the Add or 

Replace Point Dataset dialog box.  See "Displaying multiple vector datasets" for 
instructions

3 INTREPID prompts you specify the point dataset, using an Open dialog box.  See 
"Specifying input and output files" for details.

4 After you specify the dataset, INTREPID requests Z fields for colour, marker size, 
marker angle and marker text, using a field choice dialog box. If you don’t want to 
specify a field for a display attribute, click Cancel for that attribute. 

5 After you assign fields to the display attributes, INTREPID displays the dataset.

>> To turn point dataset display on and off
Use Hide Points in the Points Display menu to show or hide the point datasets you 
have loaded.  The menu option has a check mark if points display is hidden.

Changing the colour, size and angle for Z field selection

>> To assign Z fields to colour, size, angle or text
If you did not specify a Z field for colour, size or angle and now want to do so, use Z 
Value as Point Colour, Z Value as Point Size, Z Value as Marker Angle or Z Value as 
Text from the Point Display menu.  INTREPID displays an Open dialog box.

>> To reassign Z fields to colour, size, angle or text
If you want to change your Z field selection, reload (and replace) the point dataset 
using Load Point Dataset from the File menu, and specify the colour, size, angle and 
text Z fields as required.
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>> To turn colour, size, angle or label display on and off
Once you have specified a Z field, choose the Z Value as Point Colour, Z Value as 
Point Size, Z Value as Marker Angle or Z Value as Text from the Point Display menu 
to turn the display on or off.  The options have check marks against them if they are 
turned on.

Polygon dataset display
You can include polygon datasets in the display in two ways, with or without labels:
• Load and display existing polygon datasets
• Trace new polygons and save them as polygon datasets if required. 
Use the Polygon Display menu to control polygon display.

Displaying existing polygon datasets

>> To load an existing polygon dataset
1 Choose Load Polygon Dataset from the File menu. INTREPID displays an Open 

dialog box.
2 Specify the polygon dataset you require.  (See "Specifying input and output files" 

for instructions).  INTREPID displays the Optional Label Field dialog box.  

3 If the dataset has a label field, select the field (Tag in our example) and click OK 
(You can turn label display on and off).  INTREPID dsplays the dataset.
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>> To add a label to an existing polygon dataset
Before loading the dataset into the Visualisation tool, use the Spreadsheet Editor to 
add a new group by text field.  We normally use the field name Tag.  See "Spreadsheet 
Editor (T15)" for instructions.

Creating new polygons and polygon datasets

>> To trace a new polygon in the display
1 Select Zoom or Trace mouse mode.
2 Choose Trace a Polygon from the Polygon Display menu.
3 Click the vertices of the polygon you require.  Do not attempt to close the polygon 

by clicking points.
4 Choose Close Traced Polygon from the Polygon Display menu.  You may need to 

redraw the display before the last line of the polygon apears.

>> To save a traced polygon as a new polygon dataset
1 Trace and close the polygon.
2 Choose Save Traced Polygon As from the Polygon Display menu.   INTREPID 

displays the Traced Polygon Label dialog box

3 Specify a label for the polygon and click OK.  INTREPID stores this in the Tag 
field of the dataset.  INTREPID displays a Save As dialog box.  

4 Specify the name of the new datasset. See "Specifying input and output files" for 
instructions.
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>> To erase a polygon you have traced.
Choose Erase Traced Polygon from the Polygon Display menu.  

Controlling polygon display

>> To turn label and polygon display on and off
Use Hide Labels in the Polygon Display menu to turn label display on and off.

Use Hide Polygons in the Polygon Display menu to turn polygon display on and off.

Help
You can use the Help menu to display help text on the topics shown in the menu 
illustration below.

Exit
To exit from Visualisation tool choose Quit from the file menu.

Displaying options and using task specification files 
Displaying options

To display the current line dataset file specifications and a record of any line editing 
you have performed, choose Report from the Window menu.   

INTREPID displays the Visualisation tool Report window containing this 
information.
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Using task specification files
You can store line dataset file specifications for Visualisation tool in task specification 
(.job) files. 

Note: The current version of the Visualisation tool tool can only record a single line 
dataset in task specification files.  

>> To create a task specification file with the Visualisation tool
1 Specify line dataset file and fields.
2 Choose Save Options from the File menu.  Specify a task specification file 

(INTREPID will add the extension .job)  INTREPID will create the file with the 
settings current at the time of the Save Options operation.

For full instructions on creating and editing task specification files see "INTREPID 
task specification (.job) files (R06)".  

>> To use a task specification file in an interactive Visualisation tool session
Load the task specification (.job) file (File menu, Load Options) (Only line dataset 
input file specifications will be used). 

>> To display results in a batch mode task
Include the task specification (.job) file in larger batch task.  INTREPID displays 
the dataset when it reaches that stage of the task.  You can use this to show results 
from the batch task.

Task specification file example

Process Begin
Name = visual
Parameters Begin

Region Begin
Projection= “TMAMG54”
Datum = “AGD66”

Region End
Parameters End
Xin = C:/Intrepid/tutorials/ebagoola_S..DIR/x
Yin = C:/Intrepid/tutorials/ebagoola_S..DIR/y

Process End
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Frequently asked questions
Q : What kinds of point datasets are there?
Point datasets include the following: 
• Random point data such as terrestrial gravity observations, geochemical survey 

data. 
Any type of data that is not collected along a series of regularly spaced lines, must 
be imported into INTREPID as a point dataset.  Even if you collected the data 
along lines, you must organise this data into a series of lines to reflect this before 
import.  If the data is not grouped into lines, you have to imprt it into a point 
dataset. 
For example, magnetic data can sometimes be transported as ASCII files 
containing only XYZ values.  In this case the line structure reflecting the way the 
data was collected has been lost.

• INTREPID can generate point datasets from existing gridded or line data. The 
most important are: 
• Point datasets of depth estimates plus other attributes, generated by the 

Euler deconvolution tool .  See "Euler Deconvolution (T44)".
• Point datasets of depth estimates plus other attributes (such as dip, strike, 

magnetic susceptibility), generated by the Naudy Automatic Modelling tool.  
See "Naudy Automatic Model interpretation (T43)". 

• Point datasets of geological trend estimates, generated by the Gridding tool.  
See "Gridding (T22)".

• Point datasets of anomaly points, which indicate the maximum and minimum 
anomaly points in a dataset, generated by the Magmage Magnetics 
Interpretation tool.  See "Magnetic interpretation (MagMage) (T42)".

These Point datasets can contain few or many attributes. At the very least they 
will contain X and Y spatial information plus at least one Z field.
The following table shows the number of Z fields contained in a number of point 
dataset types.

Q : What are the conventions for displaying datasets?
There are no hard and fast conventions for displaying datasets. We often find the 
most effective way through trial and error. 

INTREPID displays a plan view of data. This is adequate for datasets that are 
essentially 2 dimensional, such as grids, line data and point data. 

Point datasets with a depth field, such as Naudy and Euler datasets, are three 
dimensional.  To help us visualise this data meaningfully, INTREPID provides the 
four point display attributes colour, marker size, marker angle and marker text.  

Points Dataset Type No of Z Fields

Trend (MagMage) 4

Anomaly (Gridding) 7

Euler 13

Naudy 25
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Q : What field should I assign to each attribute in a point dataset display?
Point dataset display has four display options—colour, marker size, marker angle 
and marker text. 

Generally, use colour for the primary Z field, size to highlight 'reliability' of the data, 
and marker angle for direction attributes like bearing or body strike. 

These are only guidelines—you might well use symbol size to distinguish data of 
different ages, or colour to highlight data that fulfils a certain condition. It really 
depends on the task at hand and how you prefer to visualise data. 

For a typical two dimensional point dataset such as one with gravity data, you would 
generally assign the primary Z field (gravity value) to point colour.

For a point dataset containing trend information, assign the primary Z field (gravity 
or magnetic value) to point colour and the bearing field to marker angle.

For a point dataset containing anomaly points information, assign either the Z field 
or the structure attribute to colour, and direction to marker angle.

For point datasets containing a depth attribute, assign depth to colour.  You can 
assign reliability to marker size and this will give a sense of how 'significant' the data 
point may be. Assign strike to marker angle.

Q : Do you have any tips or conventions about line or grid dataset display?
• Ternary grid dataset display is for Potassium, Uranium, Thorium radiometric 

grids to create a ternary (RGB) display.
• You can use spatial convolution to change a grid before displaying it.  INTREPID 

has an extensive library of convolution kernels.  Use the grey scale option for 
display.  See "Spatial Convolution Grid Filters (T34)" for details.
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